<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" xml:lang="en-US" prefix="og: http://ogp.me/ns#">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0"/>
<!-- This site is optimized with the Yoast SEO plugin v5.5.1 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Letter to the editor-Green - Mesquite Local News</title>
<link rel="canonical" href="http://mesquitelocalnews.com/2017/10/letter-editor-green/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Letter to the editor-Green - Mesquite Local News" />
<meta property="og:description" content="It was a sad morning; we just learn that our Zumba Gold instructor at the Senior Center Griseyda Belalcazar has tendered her resignation.  Why did she give notice to leave a job she loves and is excellent at?  She clearly loves us her students and does her job at the senior center efficiently. I have &hellip;" />
<meta property="og:url" content="http://mesquitelocalnews.com/2017/10/letter-editor-green/" />
<meta property="og:site_name" content="Mesquite Local News" />
<meta property="article:section" content="Letters to the Editor" />
<meta property="article:published_time" content="2017-10-20T07:16:57-07:00" />
<meta property="og:image" content="http://mesquitelocalnews.com/wp-content/uploads/2014/08/mesquite-square-logo.jpg" />
<meta property="og:image:width" content="368" />
<meta property="og:image:height" content="368" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/mesquitelocalnews.com\/","name":"Mesquite Local News","potentialAction":{"@type":"SearchAction","target":"http:\/\/mesquitelocalnews.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mesquite Local News &raquo; Feed" href="http://mesquitelocalnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mesquite Local News &raquo; Comments Feed" href="http://mesquitelocalnews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mesquite Local News &raquo; Letter to the editor-Green Comments Feed" href="http://mesquitelocalnews.com/2017/10/letter-editor-green/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.2.3 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
		var disableStr = 'ga-disable-UA-43030488-4';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-43030488-4', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/mesquitelocalnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='flick-css'  href='http://mesquitelocalnews.com/wp-content/plugins/mailchimp//css/flick/flick.css?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='mailchimpSF_main_css-css'  href='http://mesquitelocalnews.com/?mcsf_action=main_css&#038;ver=4.8.2' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='mailchimpSF_ie_css-css'  href='http://mesquitelocalnews.com/wp-content/plugins/mailchimp/css/ie.css?ver=4.8.2' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='metro-theme-css'  href='http://mesquitelocalnews.com/wp-content/themes/metro/style.css?ver=2.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://mesquitelocalnews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-css'  href='http://fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=2.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css'  href='http://mesquitelocalnews.com/wp-content/plugins/simple-social-icons/css/style.css?ver=2.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css'  href='http://mesquitelocalnews.com/wp-content/plugins/easy-fancybox/fancybox/jquery.fancybox-1.3.8.min.css?ver=1.6' type='text/css' media='screen' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://mesquitelocalnews.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.3' type='text/css' media='all' />
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-content/plugins/mailchimp//js/scrollTo.js?ver=1.5.7'></script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-includes/js/jquery/jquery.form.min.js?ver=3.37.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mailchimpSF = {"ajax_url":"http:\/\/mesquitelocalnews.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-content/plugins/mailchimp//js/mailchimp.js?ver=1.5.7'></script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-content/plugins/mailchimp//js/datepicker.js?ver=4.8.2'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-content/themes/genesis/lib/js/html5shiv.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-content/themes/metro/js/backstretch.js?ver=1.0.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var BackStretchImg = {"src":"http:\/\/mesquitelocalnews.com\/wp-content\/uploads\/2014\/05\/background.jpg"};
/* ]]> */
</script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-content/themes/metro/js/backstretch-set.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script>
<link rel='https://api.w.org/' href='http://mesquitelocalnews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://mesquitelocalnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://mesquitelocalnews.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.2" />
<link rel='shortlink' href='http://wp.me/p4VO0T-80z' />
<link rel="alternate" type="application/json+oembed" href="http://mesquitelocalnews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fmesquitelocalnews.com%2F2017%2F10%2Fletter-editor-green%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://mesquitelocalnews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fmesquitelocalnews.com%2F2017%2F10%2Fletter-editor-green%2F&#038;format=xml" />
<script type="text/javascript">
        jQuery(function($) {
            $('.date-pick').each(function() {
                var format = $(this).data('format') || 'mm/dd/yyyy';
                format = format.replace(/yyyy/i, 'yy');
                $(this).datepicker({
                    autoFocusNextInput: true,
                    constrainInput: false,
                    changeMonth: true,
                    changeYear: true,
                    beforeShow: function(input, inst) { $('#ui-datepicker-div').addClass('show'); },
                    dateFormat: format.toLowerCase(),
                });
            });
            d = new Date();
            $('.birthdate-pick').each(function() {
                var format = $(this).data('format') || 'mm/dd';
                format = format.replace(/yyyy/i, 'yy');
                $(this).datepicker({
                    autoFocusNextInput: true,
                    constrainInput: false,
                    changeMonth: true,
                    changeYear: false,
                    minDate: new Date(d.getFullYear(), 1-1, 1),
                    maxDate: new Date(d.getFullYear(), 12-1, 31),
                    beforeShow: function(input, inst) { $('#ui-datepicker-div').removeClass('show'); },
                    dateFormat: format.toLowerCase(),
                });

            });

        });
    </script>
    <style type="text/css" media="screen">
      div.printfriendly a, div.printfriendly a:link, div.printfriendly a:hover, div.printfriendly a:visited {
        text-decoration: none;
        border: none;
      }
    </style>
           <style type="text/css" media="screen">
          div.printfriendly {
            margin: 1px 0px 3px 0px;
            position: relative;
            z-index: 1000;
          }
          div.printfriendly a, div.printfriendly a:link, div.printfriendly a:visited {
            font-size: 14px;
            color: #6D9F00;
            vertical-align: bottom;
          }
          .printfriendly a {
            box-shadow:none;
          }
          .printfriendly a:hover {
            cursor: pointer;
          }
          .printfriendly a img  {
            border: none;
            padding:0;
            margin-right: 6px;
            box-shadow: none;
            -webkit-box-shadow: none;
            -moz-box-shadow: none;
          }
          .printfriendly a span{
            vertical-align: bottom;
          }
          .pf-alignleft {
            float: left;
          }
          .pf-alignright {
            float: right;
          }
          div.pf-aligncenter {
            display: block;
            margin-left: auto;
            margin-right: auto;
            text-align: center;
          }
        </style>
        <style type="text/css" media="print">
          .printfriendly {
            display: none;
          }
        </style>

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel="icon" href="http://mesquitelocalnews.com/wp-content/themes/metro/images/favicon.ico" />
<link rel="pingback" href="http://mesquitelocalnews.com/xmlrpc.php" />
<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/62617687/Mesquite2ndSidebar', [300, 250], 'div-gpt-ad-1444866718347-0').addService(googletag.pubads());
    googletag.defineSlot('/62617687/Mesquite3rdSidebar', [300, 250], 'div-gpt-ad-1444866718347-1').addService(googletag.pubads());
    googletag.defineSlot('/62617687/Mesquite5thSidebar', [300, 250], 'div-gpt-ad-1444866718347-2').addService(googletag.pubads());
googletag.defineSlot('/62617687/Mesquite6thSidebar', [300, 250], 'div-gpt-ad-1451678837751-0').addService(googletag.pubads());
    googletag.defineSlot('/62617687/MesquiteFullBanner', [468, 60], 'div-gpt-ad-1444866718347-3').addService(googletag.pubads());
    googletag.defineSlot('/62617687/MesquiteLeaderboard', [728, 90], 'div-gpt-ad-1444866718347-4').addService(googletag.pubads());
    googletag.defineSlot('/62617687/MesquiteMobileLeader', [320, 50], 'div-gpt-ad-1444866718347-5').addService(googletag.pubads());
    googletag.defineSlot('/62617687/MesquiteTopSidebar', [300, 250], 'div-gpt-ad-1444866718347-6').addService(googletag.pubads());
    googletag.defineSlot('/62617687/Mesquite4thSidebar', [300, 250], 'div-gpt-ad-1444866718347-7').addService(googletag.pubads());
googletag.defineSlot('/62617687/MesquiteEndLeader', [728, 90], 'div-gpt-ad-1444867769298-0').addService(googletag.pubads());
    googletag.defineSlot('/62617687/MesquiteEndFullBanner', [468, 60], 'div-gpt-ad-1444867769298-1').addService(googletag.pubads());
    googletag.defineSlot('/62617687/MesquiteEndMobileLeader', [320, 50], 'div-gpt-ad-1444867769298-2').addService(googletag.pubads());
googletag.defineSlot('/62617687/Mesquite7thSidebar', [300, 250], 'div-gpt-ad-1462814460708-0').addService(googletag.pubads());
googletag.defineSlot('/62617687/Mesquite8thSidebar', [300, 250], 'div-gpt-ad-1463676173883-0').addService(googletag.pubads());
googletag.defineSlot('/62617687/Mesquite9thSidebar', [300, 250], 'div-gpt-ad-1474067077888-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
<meta property="fb:pages" content="152547778130177" /><style type="text/css">#header { background: url(http://mesquitelocalnews.com/wp-content/uploads/2014/05/cropped-header-background-white.jpg) no-repeat !important; }</style>
<style type="text/css" media="screen"> .simple-social-icons ul li a, .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus { background-color: #999999 !important; border-radius: 3px; color: #ffffff !important; border: 0px #ffffff solid !important; font-size: 13px; padding: 7px; }  .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus { background-color: #666666 !important; border-color: #ffffff !important; color: #ffffff !important; }  .simple-social-icons ul li a:focus { outline: 1px dotted #666666 !important; }</style>
<!-- Easy FancyBox 1.6 using FancyBox 1.3.8 - RavanH (http://status301.net/wordpress-plugins/easy-fancybox/) -->
<script type="text/javascript">
/* <![CDATA[ */
var fb_timeout = null;
var fb_opts = { 'overlayShow' : true, 'hideOnOverlayClick' : true, 'showCloseButton' : true, 'margin' : 20, 'centerOnScroll' : true, 'enableEscapeButton' : true, 'autoScale' : true };
var easy_fancybox_handler = function(){
	/* IMG */
	var fb_IMG_select = 'a[href*=".jpg"]:not(.nolightbox,li.nolightbox>a), area[href*=".jpg"]:not(.nolightbox), a[href*=".jpeg"]:not(.nolightbox,li.nolightbox>a), area[href*=".jpeg"]:not(.nolightbox), a[href*=".png"]:not(.nolightbox,li.nolightbox>a), area[href*=".png"]:not(.nolightbox), a[href*=".webp"]:not(.nolightbox,li.nolightbox>a), area[href*=".webp"]:not(.nolightbox)';
	jQuery(fb_IMG_select).addClass('fancybox image');
	var fb_IMG_sections = jQuery('div.gallery ');
	fb_IMG_sections.each(function() { jQuery(this).find(fb_IMG_select).attr('rel', 'gallery-' + fb_IMG_sections.index(this)); });
	jQuery('a.fancybox, area.fancybox, li.fancybox a').fancybox( jQuery.extend({}, fb_opts, { 'transitionIn' : 'elastic', 'easingIn' : 'easeOutBack', 'transitionOut' : 'elastic', 'easingOut' : 'easeInBack', 'opacity' : false, 'hideOnContentClick' : false, 'titleShow' : true, 'titlePosition' : 'over', 'titleFromAlt' : true, 'showNavArrows' : true, 'enableKeyboardNav' : true, 'cyclic' : false }) );
}
var easy_fancybox_auto = function(){
	/* Auto-click */
	setTimeout(function(){jQuery('#fancybox-auto').trigger('click')},1000);
}
/* ]]> */
</script>
</head>
<body class="post-template-default single single-post postid-30787 single-format-standard custom-background custom-header header-image content-sidebar"><div id="wrap"><div class="before-header"></div><!-- end .before-header --><div id="header"><div class="wrap"><div id="title-area"><p id="title"><a href="http://mesquitelocalnews.com/">Mesquite Local News</a></p></div><div class="widget-area header-widget-area"><div id="text-25" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="http://mesquitelocalnews.com/category/eedition/"><img src="https://i0.wp.com/mesquitelocalnews.com/wp-content/uploads/2016/02/page.jpg" data-recalc-dims="1"></a></div>
		</div></div>
<div id="search-4" class="widget widget_search"><div class="widget-wrap"><form method="get" class="searchform search-form" action="http://mesquitelocalnews.com/" role="search" ><input type="text" value="Search this website &#x2026;" name="s" class="s search-input" onfocus="if (&#039;Search this website &#x2026;&#039; === this.value) {this.value = &#039;&#039;;}" onblur="if (&#039;&#039; === this.value) {this.value = &#039;Search this website &#x2026;&#039;;}" /><input type="submit" class="searchsubmit search-submit" value="Search" /></form></div></div>
<div id="text-22" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><center><strong>NPA 2015 General Excellence Award</strong> 


(702) 346-6397<center></div>
		</div></div>
</div></div></div><div class="after-header"></div><!-- end .after-header --><div id="nav"><div class="wrap"><ul id="menu-primary-nav-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-134" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-134"><a href="http://mesquitelocalnews.com/category/news/">News</a>
<ul  class="sub-menu">
	<li id="menu-item-135" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-135"><a href="http://mesquitelocalnews.com/category/news/local-news/">Local News</a></li>
	<li id="menu-item-142" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-142"><a href="http://mesquitelocalnews.com/category/news/arizona-strip/">Arizona Strip</a></li>
	<li id="menu-item-11530" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11530"><a href="http://mesquitelocalnews.com/category/news/business/building-permit-reports/">Building Permit Reports</a></li>
	<li id="menu-item-320" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-320"><a href="http://mesquitelocalnews.com/category/news/business/">Business</a>
	<ul  class="sub-menu">
		<li id="menu-item-321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321"><a href="http://mesquitelocalnews.com/category/news/business/business-news/">Business News</a></li>
	</ul>
</li>
	<li id="menu-item-139" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139"><a href="http://mesquitelocalnews.com/category/news/community/">Community</a></li>
	<li id="menu-item-140" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-140"><a href="http://mesquitelocalnews.com/category/news/schools/">Schools</a></li>
	<li id="menu-item-138" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138"><a href="http://mesquitelocalnews.com/category/news/clark-county/">Clark County</a></li>
	<li id="menu-item-141" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141"><a href="http://mesquitelocalnews.com/category/news/state/">State</a></li>
	<li id="menu-item-137" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137"><a href="http://mesquitelocalnews.com/category/news/fire-department/">Fire Department</a></li>
	<li id="menu-item-136" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136"><a href="http://mesquitelocalnews.com/category/news/police-beat/">Police Beat</a></li>
	<li id="menu-item-143" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-143"><a href="http://mesquitelocalnews.com/category/news/police-blotter/">Police Blotter</a></li>
	<li id="menu-item-1068" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1068"><a href="http://mesquitelocalnews.com/category/news/politics-government/">Politics / Government</a>
	<ul  class="sub-menu">
		<li id="menu-item-17237" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17237"><a href="http://mesquitelocalnews.com/category/elections-2016/">Elections 2016</a></li>
	</ul>
</li>
	<li id="menu-item-11528" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11528"><a href="http://mesquitelocalnews.com/category/news/business/visitor-statistics/">Visitor Statistics</a></li>
</ul>
</li>
<li id="menu-item-565" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-565"><a href="http://mesquitelocalnews.com/category/calendar/">Calendar</a>
<ul  class="sub-menu">
	<li id="menu-item-566" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-566"><a href="http://mesquitelocalnews.com/category/calendar/">Community Calendar</a></li>
</ul>
</li>
<li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-317"><a href="http://mesquitelocalnews.com/category/sports/">Sports</a>
<ul  class="sub-menu">
	<li id="menu-item-556" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-556"><a href="http://mesquitelocalnews.com/category/sports/bowling/">Bowling</a></li>
	<li id="menu-item-559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-559"><a href="http://mesquitelocalnews.com/category/sports/high-school/">High School</a></li>
	<li id="menu-item-16556" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16556"><a href="http://mesquitelocalnews.com/category/sports/athlete-of-the-week/">Athlete of the Week</a></li>
	<li id="menu-item-557" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-557"><a href="http://mesquitelocalnews.com/category/sports/community-sports/">Community</a></li>
	<li id="menu-item-4409" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4409"><a href="http://mesquitelocalnews.com/category/sports/geezers-softball/">Geezers Softball</a></li>
	<li id="menu-item-558" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-558"><a href="http://mesquitelocalnews.com/category/sports/golf/">Golf</a></li>
	<li id="menu-item-3781" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3781"><a href="http://mesquitelocalnews.com/category/sports/long-drive/">Long Drive</a></li>
	<li id="menu-item-560" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-560"><a href="http://mesquitelocalnews.com/category/sports/rec-center/">Rec Center</a></li>
	<li id="menu-item-561" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-561"><a href="http://mesquitelocalnews.com/category/sports/senior-games/">Senior Games</a></li>
	<li id="menu-item-8644" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8644"><a href="http://mesquitelocalnews.com/category/sports/virgin-valley-little-league/">Virgin Valley Little League</a></li>
</ul>
</li>
<li id="menu-item-318" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-318"><a href="http://mesquitelocalnews.com/category/opinion/">Opinion</a>
<ul  class="sub-menu">
	<li id="menu-item-562" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-562"><a href="http://mesquitelocalnews.com/category/opinion/editorials/">Editorials</a></li>
	<li id="menu-item-319" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-319"><a href="http://mesquitelocalnews.com/category/opinion/letters-to-the-editor/">Letters to the Editor</a></li>
	<li id="menu-item-15869" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15869"><a href="http://mesquitelocalnews.com/category/opinion/weekly-cartoon/">Weekly Cartoon</a></li>
	<li id="menu-item-563" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-563"><a href="http://mesquitelocalnews.com/category/opinion/guest-columnist/">Guest Columnist</a></li>
	<li id="menu-item-567" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-567"><a href="http://mesquitelocalnews.com/letter-to-the-editor/">Submit Letter to the Editor</a></li>
</ul>
</li>
<li id="menu-item-383" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-383"><a href="http://mesquitelocalnews.com/category/living/">Living</a>
<ul  class="sub-menu">
	<li id="menu-item-16557" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16557"><a href="http://mesquitelocalnews.com/category/living/apples-for-teachers/">Apples for Teachers</a></li>
	<li id="menu-item-384" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-384"><a href="http://mesquitelocalnews.com/category/living/arts/">Arts</a></li>
	<li id="menu-item-18301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18301"><a href="http://mesquitelocalnews.com/category/living/classifieds/">Classifieds</a></li>
	<li id="menu-item-386" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-386"><a href="http://mesquitelocalnews.com/category/living/clubs-groups/">Clubs / Groups</a></li>
	<li id="menu-item-385" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-385"><a href="http://mesquitelocalnews.com/category/living/church-news-directory/">Church News / Directory</a></li>
	<li id="menu-item-1062" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1062"><a href="http://mesquitelocalnews.com/category/living/community-announcements/">Community Announcements</a></li>
	<li id="menu-item-1063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1063"><a href="http://mesquitelocalnews.com/category/living/entertainment/">Entertainment</a></li>
	<li id="menu-item-3619" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3619"><a href="http://mesquitelocalnews.com/category/columns/featured-realtor/">Featured Realtor</a></li>
	<li id="menu-item-10858" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10858"><a href="http://mesquitelocalnews.com/category/living/featured-restaurants/">Featured Restaurants</a></li>
	<li id="menu-item-1066" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1066"><a href="http://mesquitelocalnews.com/category/living/healthcare-news/">Healthcare News</a></li>
	<li id="menu-item-5451" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5451"><a href="http://mesquitelocalnews.com/category/living/house-home-special/">House &#038; Home Special</a></li>
	<li id="menu-item-16555" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16555"><a href="http://mesquitelocalnews.com/category/living/musician-of-the-week/">Musician of the Week</a></li>
	<li id="menu-item-1067" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1067"><a href="http://mesquitelocalnews.com/category/living/obituaries/">Obituaries</a></li>
	<li id="menu-item-387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-387"><a href="http://mesquitelocalnews.com/category/living/pet-parade/">Pet Parade</a></li>
	<li id="menu-item-3147" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3147"><a href="http://mesquitelocalnews.com/category/living/senior-center-news/">Senior Center News</a></li>
	<li id="menu-item-388" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-388"><a href="http://mesquitelocalnews.com/category/living/veterans/">Veterans</a></li>
</ul>
</li>
<li id="menu-item-440" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-440"><a href="http://mesquitelocalnews.com/category/columns/">Columns</a>
<ul  class="sub-menu">
	<li id="menu-item-443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-443"><a href="http://mesquitelocalnews.com/category/columns/blondies-babbles/">Blondie’s Babbles</a></li>
	<li id="menu-item-2448" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2448"><a href="http://mesquitelocalnews.com/category/columns/from-the-mayor/">From the Mayor</a></li>
	<li id="menu-item-570" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-570"><a href="http://mesquitelocalnews.com/category/columns/front-porch-wisdom/">Front Porch Wisdom</a></li>
	<li id="menu-item-571" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-571"><a href="http://mesquitelocalnews.com/category/columns/is-this-you/">Is This You?</a></li>
	<li id="menu-item-445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-445"><a href="http://mesquitelocalnews.com/category/columns/jobs-the-economy/">Jobs &#038; The Economy</a></li>
	<li id="menu-item-21066" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21066"><a href="http://mesquitelocalnews.com/category/columns/lessons-in-government/">Lessons in Government</a></li>
	<li id="menu-item-15030" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15030"><a href="http://mesquitelocalnews.com/category/columns/making-sentences/">Making Sentences</a></li>
	<li id="menu-item-2072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2072"><a href="http://mesquitelocalnews.com/category/columns/point-of-view/">Point Of View</a></li>
	<li id="menu-item-3146" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3146"><a href="http://mesquitelocalnews.com/category/columns/sun-city-gourmet-club/">Sun City Gourmet Club</a></li>
	<li id="menu-item-568" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-568"><a href="http://mesquitelocalnews.com/category/columns/this-week-in-history/">This Week in History</a></li>
	<li id="menu-item-1700" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1700"><a href="http://mesquitelocalnews.com/category/columns/tom-mitchell/">Tom Mitchell</a></li>
	<li id="menu-item-16590" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16590"><a href="http://mesquitelocalnews.com/category/columns/triptalkin/">Triptalkin&#8217;</a></li>
	<li id="menu-item-27164" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27164"><a href="http://mesquitelocalnews.com/category/columns/weekly-words-of-wisdom/">Weekly Words of Wisdom</a></li>
</ul>
</li>
<li id="menu-item-26361" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26361"><a href="http://mesquitelocalnews.com/classifieds/">Classifieds</a></li>
<li id="menu-item-8372" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-8372"><a href="http://mesquitelocalnews.com/category/annual-events/">Annual Events</a>
<ul  class="sub-menu">
	<li id="menu-item-8373" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8373"><a href="http://mesquitelocalnews.com/category/annual-events/4th-of-july-celebration/">4th of July Celebration</a></li>
	<li id="menu-item-27247" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27247"><a href="http://mesquitelocalnews.com/category/best-of-mesquite/best-of-mesqutie-2017/">Best of Mesquite 2017</a></li>
	<li id="menu-item-8645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8645"><a href="http://mesquitelocalnews.com/category/annual-events/mesquite-days/">Mesquite Days</a></li>
	<li id="menu-item-8375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8375"><a href="http://mesquitelocalnews.com/category/annual-events/mesquite-senior-games/">Mesquite Senior Games</a></li>
	<li id="menu-item-9215" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9215"><a href="http://mesquitelocalnews.com/category/annual-events/mesquite-toes-events/">Mesquite Toes Events</a></li>
	<li id="menu-item-8376" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8376"><a href="http://mesquitelocalnews.com/category/annual-events/ms-senior-mesquite/">Ms. Senior Mesquite</a></li>
	<li id="menu-item-15942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15942"><a href="http://mesquitelocalnews.com/category/annual-events/relay-for-life/">Relay for Life</a></li>
</ul>
</li>
<li id="menu-item-21660" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21660"><a href="http://mesquitelocalnews.com/nevada-business/">Nevada Business</a></li>
</ul></div></div><div id="inner"><div class="before-content-sidebar-wrap"><div id="text-2" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div class="ad-desktop">
<center><!-- /62617687/MesquiteLeaderboard -->
<div id='div-gpt-ad-1444866718347-4' style='height:90px; width:728px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1444866718347-4'); });
</script>
</div><center></div>
<div class="ad-tablet">
<center><!-- /62617687/MesquiteFullBanner -->
<div id='div-gpt-ad-1444866718347-3' style='height:60px; width:468px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1444866718347-3'); });
</script>
</div>
<center>
</div>
<div class="ad-mobile">
<center><!-- /62617687/MesquiteMobileLeader -->
<div id='div-gpt-ad-1444866718347-5' style='height:50px; width:320px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1444866718347-5'); });
</script>
</div>
<center>
</div>
<div id="above-header-weather"></div></div>
		</div></div></div><!-- end .before-content-sidebar-wrap --><div id="content-sidebar-wrap"><div id="content" class="hfeed"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <a href="http://mesquitelocalnews.com/"><span>Home</span></a> <span aria-label="breadcrumb separator">/</span> <a href="http://mesquitelocalnews.com/category/opinion/"><span>Opinion</span></a> <span aria-label="breadcrumb separator">/</span> <a href="http://mesquitelocalnews.com/category/opinion/letters-to-the-editor/"><span>Letters to the Editor</span></a> <span aria-label="breadcrumb separator">/</span> Letter to the editor-Green</div><div class="post-30787 post type-post status-publish format-standard has-post-thumbnail hentry category-letters-to-the-editor category-top-stories entry"><h1 class="entry-title">Letter to the editor-Green</h1>
<div class="printfriendly pf-alignleft"><a href="#" rel="nofollow" onclick="window.print();if(typeof(_gaq) != 'undefined') { _gaq.push(['_trackEvent','PRINTFRIENDLY', 'print', 'NULL']);
          }else if(typeof(ga) != 'undefined') {  ga('send', 'event','PRINTFRIENDLY', 'print', 'NULL'); } return false;" class="noslimstat" title="Printer Friendly, PDF & Email"><img style="border:none;-webkit-box-shadow:none; box-shadow:none;" src="https://cdn.printfriendly.com/buttons/print-button-nobg.png" alt="Print Friendly, PDF & Email" /></a></div> <div class="post-info"><span class="date published time" title="2017-10-20T07:16:57+00:00">October 20, 2017</span>  By <a href="http://mesquitelocalnews.com/author/mln/" title="Posts by Special to the MLN" class="author url fn" rel="author">Special to the MLN</a> <span class="post-comments"><a href="http://mesquitelocalnews.com/2017/10/letter-editor-green/#respond">Leave a Comment</a></span> </div><div class="entry-content"><div id="fsb-social-bar" class="fsb-social-bar" data-post-id="30787" data-socialite="true"><style type="text/css">            #fsb-social-bar { width: 100%; border-bottom: 1px solid #dbdbdb; border-top: 1px solid #dbdbdb; padding: 10px 0; margin: 0px 0 20px 0; float: left; background: #fff; position: relative; clear: both; }            #fsb-social-bar a { border: 0px !important }            #fsb-social-bar.fsb-fixed { position: fixed; top: -2px; z-index: 99999; }            #fsb-social-bar .fsb-title { display: block; float: left; margin: 3px 20px 0 0; font-size: 16px; font-family: Arial, Helvetica, sans-serif; text-decoration: none; color: #333; }            #fsb-social-bar .fsb-share-facebook { width: 120px; float: left; padding: 3px 0 2px; height: 25px; }            #fsb-social-bar .fsb-share-facebook.fsb-hide-count { width: 44px; overflow: hidden; margin-right: 30px; }            #fsb-social-bar .fsb-share-twitter { float: left; width: 135px; padding: 3px 0 2px; height: 25px; }            #fsb-social-bar .fsb-share-twitter.fsb-hide-count { width: 61px; overflow: hidden; margin-right: 30px; }            #fsb-social-bar .fsb-share-google { float: left; width: 105px; padding: 3px 0 2px; height: 25px; }            #fsb-social-bar .fsb-share-google.fsb-hide-count { width: 33px; overflow: hidden; margin-right: 30px; }            #fsb-social-bar .fsb-share-linkedin { float: left; width: 135px; padding: 3px 0 2px; height: 25px; }            #fsb-social-bar .fsb-share-linkedin.fsb-hide-count { width: 61px; overflow: hidden; margin-right: 30px; }            #fsb-social-bar .fsb-share-pinterest { float: left; width: 115px; padding: 3px 0 2px; height: 25px;}            #fsb-social-bar .fsb-share-pinterest.fsb-hide-count { width: 43px; overflow: hidden; margin-right: 30px; }            #fsb-social-bar .socialite { display: block; position: relative; background: url(http://mesquitelocalnews.com/wp-content/plugins/floating-social-bar/images/fsb-sprite.png) no-repeat scroll 0 0; }            #fsb-social-bar .socialite-loaded { background: none !important; }            #fsb-social-bar .fsb-service-title { display: none; }            #fsb-social-bar a { color: #333; text-decoration: none; font-size: 12px; font-family: Arial, Helvetica, sans-serif; }            #fsb-social-bar .fsb-twitter { width: 105px; height: 25px; background-position: -13px -10px; line-height: 25px; vertical-align: middle; }            #fsb-social-bar .fsb-twitter .fsb-count { width: 30px; text-align: center; display: inline-block; margin: 0px 0 0 69px; color: #333; }            #fsb-social-bar .fsb-google { width: 75px; height: 25px; background-position: -136px -10px; line-height: 25px; vertical-align: middle; }            #fsb-social-bar .fsb-google .fsb-count { width: 30px; text-align: center; display: inline-block; margin: 0px 0 0 41px; color: #333; }            #fsb-social-bar .fsb-google .socialite-button { margin: 0 !important; }            #fsb-social-bar .fsb-share-google .socialite-loaded .socialite-button{padding: 2px 0 0}            #fsb-social-bar .fsb-facebook { width: 89px; height: 25px; background-position: -231px -10px; line-height: 25px; vertical-align: middle; }            #fsb-social-bar .fsb-facebook .fsb-count { width: 30px; text-align: center; display: inline-block; margin: 0px 0 0 52px; color: #333; }            #fsb-social-bar .fsb-facebook .socialite-button { margin: 0 !important;}            #fsb-social-bar .fsb-share-facebook .socialite-loaded .socialite-button {padding: 2px 0 0}            #fsb-social-bar .fsb-linkedin { width: 105px; height: 25px; background-position: -347px -10px; line-height: 25px; vertical-align: middle; }            #fsb-social-bar .fsb-linkedin .fsb-count { width: 30px; text-align: center; display: inline-block; margin: 0px 0 0 70px; color: #333; }            #fsb-social-bar .fsb-linkedin .socialite-button { margin: 0 !important; }            #fsb-social-bar .fsb-pinterest { width: 88px; height: 25px; background-position: -484px -10px; line-height: 25px; vertical-align: middle; }            #fsb-social-bar .fsb-pinterest .fsb-count { width: 30px; text-align: center; display: inline-block; margin: 0px 0 0 50px; color: #333; }            #fsb-social-bar .fsb-pinterest .socialite-button { margin: 0 !important; }            .fsb-clear { clear: both; }            .fsb-clear:after { clear:both; content:; display:block; height:0; line-height:0; overflow:auto; visibility:hidden; zoom:1; }            @media (max-width: 768px) { #fsb-social-bar.fsb-fixed { position: relative !important; top: auto !important; } }        </style><div class="fsb-share-facebook fsb-hide-count"><a href="http://www.facebook.com/sharer.php?u=http://mesquitelocalnews.com/2017/10/letter-editor-green/" class="socialite facebook fsb-facebook" data-fsb-service="facebook" data-href="http://mesquitelocalnews.com/2017/10/letter-editor-green/" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="fsb-service-title">Facebook</span><span class="fsb-count">0</span></a></div><div class="fsb-share-twitter fsb-hide-count"><a href="https://twitter.com/share?original_referer=http%3A%2F%2Fmesquitelocalnews.com%2F&source=tweetbutton&text=Letter+to+the+editor-Green&url=http%3A%2F%2Fmesquitelocalnews.com%2F2017%2F10%2Fletter-editor-green%2F&via=" class="socialite twitter fsb-twitter" data-fsb-service="twitter" rel="nofollow" target="_blank" title="Be the first one to tweet this article!"><span class="fsb-service-title">Twitter</span><span class="fsb-count">0</span></a></div><div class="fsb-share-pinterest fsb-hide-count"><a href="http://pinterest.com/pin/create/button/?url=http://mesquitelocalnews.com/2017/10/letter-editor-green/&description=Letter+to+the+editor-Green&media=https://i1.wp.com/mesquitelocalnews.com/wp-content/uploads/2014/08/mesquite-square-logo.jpg?fit=368%2C368" class="socialite pinit fsb-pinterest" data-fsb-service="pinterest" target="_blank" rel="nofollow"><span class="fsb-service-title">Pinterest</span><span class="fsb-count">0</span></a></div><div class="fsb-share-google fsb-hide-count"><a href="https://plus.google.com/share?url=http://mesquitelocalnews.com/2017/10/letter-editor-green/" class="socialite googleplus fsb-google" data-fsb-service="google" data-size="medium" data-href="http://mesquitelocalnews.com/2017/10/letter-editor-green/" rel="nofollow" target="_blank"><span class="fsb-service-title">Google+</span><span class="fsb-count">0</span></a></div><div class="fsb-share-linkedin fsb-hide-count"><a href="https://www.linkedin.com/cws/share?url=http://mesquitelocalnews.com/2017/10/letter-editor-green/" class="socialite linkedin fsb-linkedin" data-fsb-service="linkedin" data-size="medium" data-href="http://mesquitelocalnews.com/2017/10/letter-editor-green/" rel="nofollow" target="_blank"><span class="fsb-service-title">LinkedIn</span><span class="fsb-count">0</span></a></div></div><div class="fsb-clear"></div><div class="pf-content"><p>It was a sad morning; we just learn that our Zumba Gold instructor at the Senior Center Griseyda Belalcazar has tendered her resignation.  Why did she give notice to leave a job she loves and is excellent at?  She clearly loves us her students and does her job at the senior center efficiently. I have not heard complaints from other patrons since she has been with us. She will not speak of the reason why she feels she cannot stay. Except to say it is work related. It seems to me and others; someone wants her gone and is making things unpleasant for her.</p>
<p>Back a few years ago Griseyda Belalcazar was Program Coordinator at the Rec. center, she left there to come to the senior center, again there seemed to be issues at the Rec center then causing her to come to the Senior Center which was very lucky for us seniors</p>
<p>Her boss at the senior center and her boss at Rec center was and is Nick Montoya, Director of Athletics and Leisure Services. He oversees all the instructors. It seems to me management is a common denominator here that needs to be looked at to get some of these ongoing issues solved.</p>
<p>We seniors love the senior center. The Recreation center is geared more for the younger residents and kids which is good, but we need our senior center and classes that are geared to our age group. Griseyda has always made everyone feel welcome and sought to make her classes doable and fun for all abilities. Most of Mesquite residents are senior citizens who pay property taxes and dues.  We deserve to have our voices and feelings acknowledged and granted.   We patrons of the Senior Center are the best judges of management and supporters of the center. Not someone sitting at a city desk that never uses the senior uses the senior center.</p>
<p>We do not want to lose Griseyda she is a good part of the core and character of the senior center with her always up-beat spirit and boundless energy. I am afraid another instructor will not get me out to exercise class as willingly as she does.</p>
<p>All of you, who agree with my sentiments and reasoning, now is the time to make your voice heard, while these issues can be resolved.  Write your own letters to the editor and make your own phone calls to the City Manager, Andy Barton before we  lose an exceptional senior instructor.</p>
<p>&nbsp;</p>
<p>Bobbie Green</p>
</div><!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://mesquitelocalnews.com/2017/10/letter-editor-green/"
    dc:identifier="http://mesquitelocalnews.com/2017/10/letter-editor-green/"
    dc:title="Letter to the editor-Green"
    trackback:ping="http://mesquitelocalnews.com/2017/10/letter-editor-green/trackback/" />
</rdf:RDF>-->
</div><div class="post-meta"><span class="categories">Filed Under: <a href="http://mesquitelocalnews.com/category/opinion/letters-to-the-editor/" rel="category tag">Letters to the Editor</a>, <a href="http://mesquitelocalnews.com/category/top-stories/" rel="category tag">Top Stories</a></span> </div></div>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span class="comments-title">Speak Your Mind</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/10/letter-editor-green/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://mesquitelocalnews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" tabindex="4" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" value="" size="30" tabindex="1" aria-required="true" /><label for="author">Name</label> <span class="required">*</span></p>
<p class="comment-form-email"><input id="email" name="email" type="text" value="" size="30" tabindex="2" aria-required="true" /><label for="email">Email</label> <span class="required">*</span></p>
<p class="comment-form-url"><input id="url" name="url" type="text" value="" size="30" tabindex="3" /><label for="url">Website</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='30787' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a72dbd4081" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="85"/></p>			</form>
			</div><!-- #respond -->
	</div><div id="sidebar" class="sidebar widget-area"><div id="text-20" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><center><!-- /62617687/MesquiteTopSidebar -->
<div id='div-gpt-ad-1444866718347-6' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1444866718347-6'); });
</script>
</div><center></div>
		</div></div>
<div id="text-4" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><center><!-- /62617687/Mesquite2ndSidebar -->
<div id='div-gpt-ad-1444866718347-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1444866718347-0'); });
</script>
</div><center></div>
		</div></div>
<div id="text-5" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><center><!-- /62617687/Mesquite3rdSidebar -->
<div id='div-gpt-ad-1444866718347-1' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1444866718347-1'); });
</script>
</div><center></div>
		</div></div>
<div id="text-13" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><center><!-- /62617687/Mesquite4thSidebar -->
<div id='div-gpt-ad-1444866718347-7' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1444866718347-7'); });
</script>
</div><center></div>
		</div></div>
<div id="text-15" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><center><!-- /62617687/Mesquite5thSidebar -->
<div id='div-gpt-ad-1444866718347-2' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1444866718347-2'); });
</script>
</div><center></div>
		</div></div>
<div id="text-21" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- /62617687/Mesquite6thSidebar -->
<center><div id='div-gpt-ad-1451678837751-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1451678837751-0'); });
</script>
</div><center></div>
		</div></div>
<div id="text-23" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><center><!-- /62617687/Mesquite7thSidebar -->
<div id='div-gpt-ad-1462814460708-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1462814460708-0'); });
</script>
</div></center></div>
		</div></div>
<div id="text-24" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><center><!-- /62617687/Mesquite8thSidebar -->
<div id='div-gpt-ad-1463676173883-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1463676173883-0'); });
</script>
</div></center></div>
		</div></div>
<div id="text-6" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><center><iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2Fpages%2FMesquite-Local-News%2F152547778130177&amp;width=336&amp;height=590&amp;colorscheme=light&amp;show_faces=true&amp;header=true&amp;stream=true&amp;show_border=true&amp;appId=113026708710122" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:100%; height:590px;" allowTransparency="true"></iframe><center></div>
		</div></div>
<div id="text-16" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle"><span class="widget-headline">Join the Conversation on Twitter</span></h4>
			<div class="textwidget">            <center><a href="https://twitter.com/hashtag/bbmnv" onclick="__gaTracker('send', 'event', 'outbound-widget', 'https://twitter.com/hashtag/bbmnv', '#bbmnv Tweets');" class="twitter-timeline"   data-widget-id="520662760569315328">#bbmnv Tweets</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script><center></div>
		</div></div>
<div id="text-19" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div style="text-align:center;"><a href="http://battlebornmedia.com"><img  src="https://i2.wp.com/www.elynews.com/wp-content/uploads/2015/01/logo.png" data-recalc-dims="1"></a></div></div>
		</div></div>
<div id="text-7" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle"><span class="widget-headline">Local Links</span></h4>
			<div class="textwidget"><ul><li><a href="http://www.mesquiteanimalshelter.petfinder.com/" target="_blank">Animal Shelter</a></li><li><a href="http://www.accessclarkcounty.com" target="_blank">Clark County</a></li><li><a href="http://www.mesquitenv.com" target="_blank">City of Mesquite</a></li><li><a href="https://www.facebook.com/desertdamesmesquitenv" target="_blank">Desert Dames</a></li><li><a href="http://www.gmaf.net" target="_blank">GMAF Arts Foundation</a></li><li><a href="http://www.mesquiteseniorgames.com/" target="_blank">Mesquite Senior Games</a></li><li><a href="http://www.mesquiteshooters.org" target="_blank">Mesquite Shooters</a></li><li><a href="http://www.mesquitetoestapteam.com/" target="_blank">Mesquite-Toes</a></li><li><a href="http://forecast.weather.gov/MapClick.php?CityName=Mesquite&amp;state=NV&amp;site=VEF&amp;lat=36.7889&amp;lon=-114.143" target="_blank">Local Weather</a></li><li><a href="http://www.relianceconnects.com" target="_blank">Reliance Connects</a></li><li><a href="http://www.mesquitefineartscenter.com" target="_blank">VVAA Artists</a></li><li><a href="http://www.vvtgnv.com/" target="_blank">VV Theatre Group</a></li><li><a href="http://www.vvh2o.com" target="_blank">VV Water District</a></li><li><a href="http://schools.ccsd.net/virginvalley/" target="_blank">VVHS</a></li><li><a href="http://www.wecareforanimals.org" target="_blank">We Care for Animals</a></li></ul></div>
		</div></div>
<div id="text-8" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle"><span class="widget-headline">Affiliates</span></h4>
			<div class="textwidget"><ul><li><a href="http://www.elynews.com/" onclick="__gaTracker('send', 'event', 'outbound-widget', 'http://www.elynews.com/', 'The Ely Times');" title="">The Ely Times</a></li><li><a href="http://lccentral.com/">Lincoln County Record</a></li><li><a href="http://mcindependentnews.com/">Mineral County Independent News</a></li><li><a href="http://eurekasentinel.com/">The Eureka Sentinel</a></li><li><a href="http://www.sparkstrib.com/">Sparks Tribune</a></li></ul></div></div>
		</div></div>
</div></div><div class="after-content-sidebar-wrap"><div id="text-9" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div class="ad-desktop">
<center><!-- /62617687/MesquiteEndLeader -->
<div id='div-gpt-ad-1444867769298-0' style='height:90px; width:728px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1444867769298-0'); });
</script>
</div><center></div>
<div class="ad-tablet">
<center>
<!-- /62617687/MesquiteEndFullBanner -->
<div id='div-gpt-ad-1444867769298-1' style='height:60px; width:468px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1444867769298-1'); });
</script>
</div>
<center>
</div>
<div class="ad-mobile">
<center><!-- /62617687/MesquiteEndMobileLeader -->
<div id='div-gpt-ad-1444867769298-2' style='height:50px; width:320px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1444867769298-2'); });
</script>
</div>
<center></div></div>
		</div></div></div><!-- end .after-content-sidebar-wrap --></div></div><div id="footer-widgets" class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><div id="black-studio-tinymce-2" class="widget widget_black_studio_tinymce"><div class="widget-wrap"><h4 class="widget-title widgettitle"><span class="widget-headline">Connect</span></h4>
<div class="textwidget"><ul>
<li><a title="About" href="http://mesquitelocalnews.com/?page_id=58">About Us</a></li>
<li><a title="Contact" href="http://mesquitelocalnews.com/?page_id=60">Contact Us</a></li>
<li><a title="Feedback" href="http://mesquitelocalnews.com/?page_id=451">Feedback</a></li>
<li><a title="Submit a News Story" href="http://mesquitelocalnews.com/?page_id=454">Submit Story</a></li>
<li><a title="Letter to the Editor" href="http://mesquitelocalnews.com/?page_id=457">Letter to the Editor</a></li>
</ul>
</div></div></div>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><div id="black-studio-tinymce-3" class="widget widget_black_studio_tinymce"><div class="widget-wrap"><h4 class="widget-title widgettitle"><span class="widget-headline">Services/Solutions</span></h4>
<div class="textwidget"><ul>
<li><a title="Advertise" href="http://mesquitelocalnews.com/?page_id=465">Advertise</a></li>
<li><a title="Classifieds" href="http://mesquitelocalnews.com/?page_id=393">Place a Classified Ad</a></li>
<li><a title="eNewsletter Signup" href="http://mesquitelocalnews.com/?page_id=459">eNewsletter Sign Up</a></li>
<li><a title="Subscribe to Mesquite Local News" href="http://mesquitelocalnews.com/?page_id=463">Mail Subscription</a></li>
</ul>
</div></div></div>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><div id="black-studio-tinymce-4" class="widget widget_black_studio_tinymce"><div class="widget-wrap"><h4 class="widget-title widgettitle"><span class="widget-headline">Social</span></h4>
<div class="textwidget"><ul>
<li><a href="http://www.facebook.com/pages/Mesquite-Local-News/152547778130177" target="_blank">Facebook</a></li>
<li><a href="http://twitter.com/mesquitelocal" target="_blank">Twitter</a></li>
<li><a href="http://mesquitelocalnews.com/feed" target="_blank">RSS</a></li>
</ul>
</div></div></div>
</div></div></div><div id="footer" class="footer"><div class="wrap"><div class="gototop"><p><a href="#wrap" rel="nofollow">Return to top of page</a></p></div><div class="creds"><p>Copyright &#x000A9;&nbsp;2017 Battle Born Media · Copyright &#x000A9;&nbsp;2017 | <a href="http://nvcmedia.com/nevada-web-design/"><strong>Nevada Web Design</strong></a> services by <a href="http://nvcmedia.com/">Nevada Central Media</a> using <a href="http://my.studiopress.com/themes/genesis/">Genesis Framework</a> by <a href="http://www.studiopress.com/">StudioPress</a></p></div></div></div>      <script type="text/javascript">

          var pfHeaderImgUrl = '';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '0';
          var pfImagesSize = 'full-size';
          var pfImageDisplayStyle = 'right';
          var pfDisableEmail = '0';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
          var pfPlatform = 'Wordpress';
      (function() {
            var e = document.createElement('script'); e.type="text/javascript";
            e.src = 'https://cdn.printfriendly.com/printfriendly.js';
            document.getElementsByTagName('head')[0].appendChild(e);
        })();
      </script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/mesquitelocalnews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201742'></script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-includes/js/comment-reply.min.js?ver=4.8.2'></script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-includes/js/wp-embed.min.js?ver=4.8.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var fsb = {"ajax":"http:\/\/mesquitelocalnews.com\/wp-admin\/admin-ajax.php","nonce":"052dd05ca1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-content/plugins/floating-social-bar/js/fsb.js?ver=1.1.7'></script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0'></script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-content/plugins/easy-fancybox/fancybox/jquery.fancybox-1.3.8.min.js?ver=1.6'></script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-content/plugins/easy-fancybox/js/jquery.easing.min.js?ver=1.4.0'></script>
<script type='text/javascript' src='http://mesquitelocalnews.com/wp-content/plugins/easy-fancybox/js/jquery.mousewheel.min.js?ver=3.1.13'></script>
<script type="text/javascript">
jQuery(document).on('ready post-load', function(){ jQuery('.nofancybox,a.pin-it-button,a[href*="pinterest.com/pin/create/button"]').addClass('nolightbox'); });
jQuery(document).on('ready post-load',easy_fancybox_handler);
jQuery(document).on('ready',easy_fancybox_auto);</script>
</body></html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced

 Served from: mesquitelocalnews.com @ 2017-10-20 07:17:46 by W3 Total Cache -->